Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2025 - 07:00 EDT
Scheduled
Scheduled Power Interruption Causing Internet & Phones Disruption in Specific Buildings Wednesday, March 12, 2025 - 7:00 am - 8:00 am
On March 12, 2025, occupants in the buildings below will experience a power blink between 7:00am – 8:00am. This brief interruption in power is needed for Facilities Maintenance staff to perform preventive maintenance on the electrical system.
Affected Buildings:
Adams Hall
Aquatic Center
Academic Research Center
Bird Arena
Boyd Hall
Brown Hall
Carr Hall
Central Food Facility
Chemistry Building
Clippinger Laboratories
Convocation Center
Crawford Hall
Dougan House
Ewing House
Golf and Tennis Clubhouse
Grosvenor Hall
Grover Center
Heritage Hall
Hoover House
Irvine Hall
James Hall
Lausche Baghouse
Living Learning Center
Luchs Hall
Mackinnon Hall
Medical Education Center
Nelson Commons
Parks Hall
Peden Stadium
Pickering Hall
Ping Center
Porter Hall
Pruitt Field
Russ Research Opportunity Center
Ryors Hall
Sargent Hall
Sook Center
Sowle Hall
Stocker Center
Surface Sciences Laboratory
Tanaka Hall
Treudley Hall
University Garage
University Service Center
Walter Hall
Walter Fieldhouse
West Green Chilled Water Plant
Wilson Hall
Wray House
Wren Stadium Complex
Please feel free to contact Facilities Operations at 593-2911 if you have any questions or concerns.
Affected Services: Wired Internet WiFi University telephones
You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Mar 06, 2025 - 14:19 EST
This scheduled maintenance affected: Internet & Phones (Internet & phones in specific buildings).