Concur
Incident Report for Ohio University
Resolved
Concur (Travel and Expense Reporting system): Service has been restored.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.
Posted 10 days ago. Sep 13, 2018 - 17:06 EDT
Investigating
Concur (Travel and Expense Reporting system): Our vendor has notified us that they are investigating issues with this service. Users are unable to log in. If already logged in, users are experiencing errors, slow processing or are logged out when performing administrative functions, attempting to create, view, save, approve expense reports or process payment requests. We will provide updates as they become available.

Affected services:
Concur

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted 10 days ago. Sep 13, 2018 - 08:48 EDT
This incident affected: Financial & HR Administration (e-Biz, etc.) (Business Systems Apps).