OHIO Systems Status

Bookshelf Online (Online Textbooks)

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 15:24 EDT

Investigating

[Service name]
Technicians are investigating issues with this service. Students will be unable to access VitalSource delivered eBooks.

We will post updates at least every [insert time] hours.

Affected services:
Bookshelf Online (Online Textbooks)

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Jun 12, 2025 - 14:56 EDT
This incident affected: Other (Other).