OHIO Systems Status

Catmail Email & Calendar

Incident Report for Ohio University

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 15:58 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2025 - 15:58 EDT

Investigating

Catmail Email & Calendar
Microsoft has notified us that they are investigating issues with this service. Users will not receive PTO request emails but at this time it seems that the manager in charge is receiving the emails.

We will post updates at least every 2 hours.

Affected services:
Catmail Email & Calendar

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Jul 23, 2025 - 13:57 EDT
This incident affected: Email & Calendar (Catmail Email).