Concur (Travel & Expense Reporting System)
Incident Report for Ohio University
Resolved
Concur (Travel & Expense Reporting System)
Service has been restored.

Contact the IT Service Desk at 740-593-1222 or https://www.ohio.edu/oit/help to report any lingering issues.

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Jul 22, 2021 - 13:18 EDT
Investigating
Concur (Travel & Expense Reporting System)
Concur is currently down. Users will be unable to access the service at this time.

We will post updates at least every 24 hours.

Affected services:
Concur

You are receiving this message either because you have subscribed to updates at https://status.ohio.edu or because you are part of the core user group for the service(s) listed above.
Posted Jul 22, 2021 - 12:11 EDT
This incident affected: Financial & HR Administration (e-Biz, etc.) (Concur).